20/03/2019 Actulización de seguridad PuTTY

 

20 de marzo de 2019

Actulización de seguridad PuTTY
ID: 20031906

Descripción

Los desarrolladores del cliente SSH PuTTY han lanzado la versión 0.71 del programa de código abierto que permite a los usuarios acceder de forma remota a los sistemas a través del protocolo de red SSH, Telnet y Rlogin. Entre las vulnerabilidades corregidas se encontraban:

1. Falsificación de autenticación. El usuario podría ser explotado por un servidor malicioso para generar un aviso de autenticación falsa de lado del cliente, con lo cual la víctima introduciría su clave privada.

2. Ejecución de código vía CHM Hijacking. Esta acción podría permitir a un atacante engañar al usuario para que ejecute código malicioso a través de un archivo CHM.

3. Desbordamiento de búfer en Unix Putty Tools. Al abrir demasiados reenvíos de puertos, provocaría un desbordamiento de búfer.

4. Reutilización de números aleatorios criptográficos. El problema reside en la forma en que el generador de números aleatorio de PuTTY usa el mismo lote de bytes aleatorios, dos veces.

5. Fallo de desbordamiento de número entero. Un servidor remoto puede activar una clave RSA corta, lo que provoca un desbordamiento debido a que PuTTY sufría de un problema debido a la falta de cambio de llaves, de tamaños de llaves RSA.

6. Ataques de denegación de servicios en terminales. Permiten que un servidor se bloquee o ralentice el terminal del cliente, enviando diferentes salidas de texto.

Esta nueva actualización se encuentra disponible para las plataformas Windows y Linux.

Producto afectado

 

  • PuTTY

Recomendación:

Para los usuarios que hagan uso de este cliente de SSH, la actualización se encuentra disponible para su descarga.

Para más información:

https://www.chiark.greenend.org.uk/~sgtatham/putty/latest.html